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Conventions Used in This Manual 

Typographic Convention 

Type Style Represents 

Example Text Words or characters that appear on the window.  These include field 
names, window titles, and pushbuttons. 

Example Text Words or characters you type into a field. 

 

Abbreviation Convention 

Abbreviation Represents 

N  Normal view of the content item editor 

A Advanced view of the content item editor 

 

Document Icons 

Icon Icon Meaning 

 

Tip – a tip is a type of note that helps the users apply the techniques 
and procedures described in the test to their specific needs.  A tip 
suggests an alternative method that may not be obvious and helps 
users understand the benefits and capabilities of the item. 

 
Note – Notes call the user‘s attention to information of special 
importance. 

 
Reference – Refers the user to another source of information. 

 
Caution – Caution advises users of actions that could potentially 
cause problems. 

 

Illustrations used in this documentation were captured in Windows XP. Thus the appearance of windows and dialog boxes may vary 
slightly from that of other versions of Windows or on a Macintosh computer. The usage possibilities of this software are constantly 
evolving. The results presented in this handbook as examples may vary according to your version of the software. 
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THIS DOCUMENTATION IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS 
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND 
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL 
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, 
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER 
IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF 
THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. COPYRIGHT HOLDERS WILL 
NOT BE LIABLE FOR ANY DIRECT, INDIRECT, SPECIAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF ANY USE OF 
THE SOFTWARE OR DOCUMENTATION.  

Windows, MacIntosh, Quicktime, Flash, WebEQ and Real Video are registered trademarks of their respective owners. 
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Introduction 

Welcome to the ANGEL 7.3 HTML Reference Manual. This guide is designed to provide 
instructors students and mentors with an understanding of the HTML Editor.  

ANGEL‘s editor is a full What You See Is What You Get (WYSIWYG) HTML editor specifically 
designed to work within the ANGEL LMS.  The editor is present any place text can be formatted 
or edited. 

Notable features include: 

 Full WYSIWYG editing everywhere you‘re able to edit content within ANGEL. 

 Simple menu options allow you find and link to any other content item within your course 
or the World Wide Web.   

 The Insert Image tool features an integrated file / web browser with the ability to select a 
graphic, seamlessly upload it to the course, and then insert the photo into the document. 

 Content template support allows for the creation of course content with a consistent look 
and feel. 

 Integrated equation editor from industry-leader WebEQ 

 Full table support makes it easier to present complex tabular data. 

 Paste from MS Word feature allows you to paste into your HTML editor directly from MS 
Word. 

 Edit window automatically resizes as you enter text – allowing the window to start small 
and expand dynamically as you add text. 

Accessing Menus 

The  HTML editor is a toolbar which contains a menu of tools which will help you enhance your 
pages within ANGEL. The editor has three modes that are implemented to best support the 
user‘s current task: 

 Full Menu – The menu bar with all 32 menu features active. 

 Partial Menu – the menu bar with 16 menu features active. Available in ANGEL‘s 
Announcement Editor, Page Banner, Data management nugget, Page Folder, 
Institutional Resource nugget, Did you know nugget, About this section nugget, Course 
News and Events nugget and Syllabus nugget. 

 Slim Menu – the menu bar with 13 menu features active. Available in ANGEL‘s Calendar 
feature. 
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The  HTML editor includes the following menus and tools: 

 

 

A B C D E F G H I J K L M N 

 

Letter Menu/Tool Description Full Partial   Slim 

A  Collapse/Expand 
toolbar arrow 

Allows you to hide the HTML editor 
toolbar 

    

B  Macro Icon Allows you to create and edit macros.       

C  Edit menu Allows you to cut, copy, paste, 
undo/redo, find, replace, select all and 
remove. 

      

D  Font Style menu Allows you to bold, underline, italicize, 
strikethrough, superscript and subscript 
text. 

  Bold, italic and 
underline only 

Bold, italic 
and 
underline 
only 

E  Link menu Allows you to enter content and web 
links, remove links and create anchors. 

  Content link, web 
link only 

Content link, 
web link only 

F  Media menu Allows you to insert and format images, 
movies and Flash presentations. 

  Images  

G  Insert menu Allows you to use an HTML Widget, 
create and modify equations, insert 
special characters, use the universal 
keyboard, insert lines and page breaks. 

  Equation editor 
and special 
characters only 

Equation 
editor only 

H  Table menu Allows you to manipulate rows, columns 
and cells.  

    

I  Form menu Allows you to create forms using 
elements such as buttons, text fields 
and form parameters. 

    

J  List menu Allows you to add bullets, numberings 
and indents. 

  Numbered and 
bulleted only 

Numbered 
and bulleted 
only 

K  Justify menu Allows you to justify your text either left, 
right, center or block. 

    

L  Text & 
Background color 

Allows you to change your text and 
background colors. 

    

M  Formatting & 
Styles arrow 

Allows you to change your styles, fonts, 
font size and format your text. 

  Font and Size only Font and 
Size only 

N  File Menu Allows you to view HTML source code, 
spell check, preview, save or change 

  Spell check only Spell check 
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document properties. only 

 

 

You will need to disable pop-up blocking features to use some tools in the HTML 
editor. Failing in disable pop-up blocking may result in loss of information in the HTML 
editor and failure of the HTML Editing features. 

Using the Toolbar and Menus 

Before you can begin using the HTML editor, you need to be able to access the menus. 

Access a menu 

To access a menu, do the following: 

 Click the ▼ symbol to expand the menu, then click the tool (e.g. cut, copy, past, web 
link, etc.) 

Access a tool 

To access a tool, do one of the following: 

 Click the tool icon in the toolbar.  

 Click the ▼ symbol to expand the menu, then click the tool (e.g. cut, copy, past, web 
link, etc.) 

Collapse the toolbar 

To collapse the toolbar, do the following: 

 Click the Collapse toolbar arrow to hide ANGEL ‘s HTML toolbar. 

Expand the toolbar 

To collapse the toolbar, do the following: 

 Click the Expand toolbar arrow to show ANGEL ‘s HTML toolbar. 
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Formatting and Editing Text and Paragraphs 

You can format text and paragraphs as you would use a word processor — to add visual 
organization, emphasis, and structure. You can change the font, size, style, color and add 
effects such as underlining. You can also control indentation, add bullets and numbers, and set 
alignment. 
 

The formatting you apply can either affect selected words or an entire paragraph. A general rule 
is that font properties (such as font, size, color and effects) can be applied to selected text, and 
paragraph properties (including alignment, bullets, numbering and formatting) affect entire 
paragraphs. For example, you can italicize a single word in a paragraph, but if you try to align 
the word to the right, the entire paragraph will be aligned. 
 

The editing tools you can use include the ability to copy, cut and paste words, sentences, and 
paragraphs as plain text or with full Word formatting.  

Formatting individual characters and words 

Properties that you can set for words or characters include:  

Icon Description 

 

 

Bold – accentuates the text.  This text is bold. 

 

 

Italic – causes the text to slant. This text is in italics. 

 

 

Underline – places a line under the text. This text is underlined. 

 
Strikethrough – places a line through the text.  This text is 
strikethough. 

 
Superscript – places the text slightly higher than other text on a 
line, such as a footnote reference mark. This text is superscript. 

 
Subscript – places the text slightly lower than other text on a line. 
Subscripts are often used in scientific formulas.  This text is subscript. 

 
Color – allows you to affect the color of text. 

 
Background color- allows you to add highlight to selected text. 

 
Style - Is as a set of pre-defined formatting instructions that you 
can use repeatedly throughout the document.  
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Icon Description 

 
Font – affects how text appears on a page. Font will default to 
browsers default  (usually Times New Roman or Times (on Macs). 

 
Font Size – affects the size of the text on a page.  

Apply bold formatting    

1. Select the text you want to change.  

2. Do one of the following: 

 Click Bold . 

 On the Font Style menu, select Bold . 

Apply italic formatting    

1. Select the text you want to change.  

2. Do one of the following: 

 Click Italic . 

 On the Font Style menu, select Italic . 

 Apply underline formatting   

1. Select the text you want to change.  

2. Do one of the following: 

 Click Underline . 

 On the Font Style menu, select Underline . 

Apply strikethrough formatting 

1. Select the text that you want to change.  

2. On the Font Style Menu of the toolbar, select Strike Through  

. 

Apply superscript text formatting    

1. Select the text that you want to change. 

2. On the Font Style Menu of the toolbar, select Superscript . 

Apply subscript text formatting    
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1. Select the text that you want to change. 

2. On the Font Style Menu of the toolbar, select Subscript . 

Change the color of text 

The text color properties affect the color of text. It can be used on a specific character or a 
whole page.  

1. Select the text you want to change.  

2. Click Text Color   

3. Click the color you want. 
 

. 

 

 

You can select more colors by clicking More Colors, pointing to the color you want, 
and by clicking it. Once you‘ve selected a color, it will show in the selected box. If 
you select another color, it will show in the highlighted box only until you click OK. 
To clear the selected color from within the color picker, click Clear. 

If you do not highlight text, your chosen text color will apply to items typed from 
that point onwards. 

 

Change the background color of text    

1. Select the text you want to change.  

2. Click Background Color .  

3. Click the color you want. 
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You can select more colors by clicking More Colors, selecting the color you want, 
and by clicking it. Once you‘ve selected a color, it will show in the Selected box. If 
you select another color, it will show in the Highlighted box only until you click 
OK. To clear the selected color from within the Select Color dialog box, click 
Clear. 

If you do not select text, your chosen text color will apply to items typed from that 
point onwards. 

Apply a different text style    

1. Select the text you want to change.  

2. Click the Style icon. 

3. Select the style you want.   

 

 
The Style properties contain both character and paragraph styles.  To apply the 
style to only the selected text, select a style with the word Text in the title. 

 

Apply a different font to text    

1. Select the text you want to change.  

2. Click Font . 

3. Select the font you want. 
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The current font is annotated by the  symbol. 

Change the size of text    

1. Select the text you want to change.  

2. Click Size . 

3. Select the font you want. 

    

Formatting paragraphs 

Properties that you can set for paragraphs include:  

Icon Description 

 
 

 

Indentation determines the distance of the paragraph from either 
the left or right margins.  

 

 

 

 

 

 

Left or right justify-determines the appearance and orientation of 
the edges of the paragraph: left-aligned, right-aligned, centered, or 
justified (justify: To adjust horizontal spacing so that text is aligned 
evenly along both the left and right margins.  

 

 
Format-allows you to select preselected text and heading format 
options from a drop-down list. 

Indent  

Indentation determines the distance of the paragraph from the left margin. 
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Increase the left indent of an entire paragraph  

1. Place the insertion point into the paragraph you want to change.  

2. On the List menu, select Increase Indent . 

Decrease the left indent of an entire paragraph  

1. Place the insertion point into the paragraph you want to change.  

2. On the List menu, select Decrease Indent . 

 

Align paragraphs horizontally on the page 

Left Align Text 

1. Place the insertion point into the paragraph you want to align to the left of the page. 

2. On the Justify menu, select Left Justify . 

Right Align Text 

1. Place the insertion point into the paragraph you want to align to the right of the page 

2. On the Justify menu, select Right Justify . 

Center Align Text 

1. Place the insertion point into the paragraph you want to align to the center of the page. 

2. Click Center Justify . 

Block Align Text 

1. Place the insertion point into the paragraph you want to align along both the left and right 
of the page. 

2. Click the arrow on the Justify Menu, select Block Justify . 

Start a new line within the same paragraph  

A line break ends the current line and continues the text on the next line of the same paragraph.  

1. Place the insertion point where you want to create a new line. 

2. Press SHIFT+ENTER.  

Format 

1. Place the insertion point into the paragraph you want to format. 

2. Click Format . 
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3. Click the text format you want. 
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Formatting Bulleted, Numbered, and Multi-level Lists 

You can add bullets or numbers to existing lines of text, or you can automatically create bulleted 
and numbered lists as you type.  

 

Icon Description 

 
Numbered lists display a sequential list of items.  

 

 
Bulleted list display a list of unordered items.  

 

Numbered list 

Numbered lists display a sequential list of items.  You can select from uupper and lowercase 
letters, numbers, or upper and lowercase Roman numerals.  

 

Lettered List Numbered List Roman Numeral List 

a. Do this first  

b. Do this second 

c. Do this third 

1. Do this first  

2. Do this second 

3. Do this third 

I. Do this first  

II. Do this second 

III. Do this third 

Create a numbered list  

1. Place insertion point at the target location.  

2. Click Insert/Remove Numbered List . 

3. Type the text you want to add next to the number, and then press ENTER.  

4. To end the list, press ENTER again. 

Create a numbered list using existing text  

1. Do one of the following: 

 Select the items to which you want to add numbering. 

 Place insertion point at the target location.  

2. Click Insert/Remove Numbered List . 

3. To end the list, press ENTER again. 

Format numbered list  

1. Right-click any item in the numbered list you want to change. 
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2. In the pop-up menu, click Numbered List Properties . 
 

3. In the Numbered List Properties: 

 

a. Type the number to start the list in the Start box. 

b. Select the number format you want from the Type drop-down list. 

c. Click OK. 

 
Click Cancel to exit the window without making changes. 

Remove a numbered list  

1. Select the text from which you want numbers removed.  

2. Click Insert/Remove Numbered List . 

 
To remove a single number, click the number, and then press BACKSPACE. 

Bulleted list 

Bulleted list are used to present a list of unordered items — that is, items that don't need to be 
numbered.  You can select from circle, disc or square bullets. 

 

Disc List Circle List Square List 

 apples  

 melons  

 grapes 

o apples  

o melons  

o grapes 

 apples  

 melons  

 grapes 
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Create a bulleted list  

1. Place insertion point at the target location.  

2. Click Insert/Remove Bulleted List . 

3. Type the text you want to add next to the bullet, and then press ENTER.  

4. To end the list, press ENTER again. 

Create a bulleted list using existing text  

1. Do one of the following: 

 Select the items to which you want to add bullets. 

 Place insertion point at the target location.  

2. Click Insert/Remove Bulleted List . 

3. To end the list, press ENTER again. 

Format bulleted list  

1. Right-click any item in the bulleted list you want to change. 

2. In the pop-up menu, click Bulleted List Properties . 

3. In the Bulleted List Properties: 

 

a. Select the list format you want from the Type drop-down list. 

b. Click OK. 

 
Click Cancel to exit the window without making changes. 

 

Remove a bulleted list  

1. Select the text from which you want bullets removed.  

2. Click Insert/Remove Bulleted List . 

 
To remove a single bullet, click the number, and then press BACKSPACE. 
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Multilevel list 

You can create lists that have multiple nested levels and specify different list formats for each 
level. For example, the following list uses different numbering styles at each level. 

Multilevel Numbered List Multilevel Bulleted List 

1. Chapter  

a. Heading  

i. Topic  

1. Detail  

ii. Topic  

1. Detail  

2. Detail  

b. Heading  

 

 Chapter  

o Heading  

 Topic  

 Detail  

 Topic  

 Detail  

 Detail  

o Heading  

 

 

Create a multilevel list  

1. Place insertion point at the target location. 

2. Click either Insert/Edit Numbered List  or Insert/Edit Bulleted List .  

3. For each item you want in the list, regardless of its level, type the item, and then press 
ENTER.   

4. When you have typed the last item, press ENTER twice to end the list.  

5. To place each item on the correct level, do one of the following:  

 To move items down to the next level, select the items, and then click Increase 

Indent .  

 To move items up to the previous level, select the items, and then click Decrease 

Indent .  

6. To apply list formats to the different levels, do one of the following: 

 Format numbered list: 

a. Right-click any item in the list you want to change. 
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b. In the pop-up menu, click the Numbered List Properties. 

         

c. In the Numbered List Properties: 

 

i. Type the number to start the list in the Start box. 

ii. Select the number format you want from the Type drop-down list. 

iii. Click OK. 

 

 Format bulleted list:    

a. Right-click any item in the list you want to change. 

b. In the pop-up menu, click the Bulleted List Properties. 

            

c. In the Bulleted List Properties: 

           

i. Select the list format you want from the Type drop-down list. 

ii. Click OK. 
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Editing Text and Paragraphs 

The Edit Menu is used to make changes to your text. Using the same type of features as a word 
processing program, you can  

 undo or redo an action  

 cut, copy or paste sections of text and images 

 paste text as plain text or with Word formatting 

 find, replace, or select all text 

 remove formatting from text 

Within this group of tasks the Paste function is represented as and icon. All functions are 

accessed through the Edit Menu . 

 

Icon Description 

 
Undo- allows you to undo the most recent action taken.  

 
Redo- allows you to redo the most recent action taken.  

 
Cut- allows you to Remove the highlighted text.  

 
Copy- allows you to copy the highlighted text.  

 
Paste- Paste the text you copied (with or without formatting)  

 
Paste as plain text- allows you to remove formatting from text before 
pasting it into the text area. 

 
Paste from Word- allows you to paste text from Word into the HTML 
editor retaining the exact replica of the Word document. You should 
always use this option when copying from Word. 

 
Find- allows you to find specific words or phrases for editing or 
deletion. 

 
Replace- allows you to replace words or phrases with new wording. 

 
Select All- allows you to select the entire text to format. 

 
Remove Format- allows you to remove all formatting from text. 

 

Undo  

Undo reverses the last action you performed in the HTML editor. Undo has a twin feature called 
Redo. You can undo 15 levels of actions. 
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 Click the arrow on the Edit Menu, select Undo . 

Redo 

Redo reverses the last Undo action. If you accidentally undo too many actions, Redo puts them 
back into your page. You can redo 15 levels of actions. 

 Click the arrow on the Edit Menu, select Redo . 

Cut 

1. Select text you want to cut. 

2. On the Edit Menu, select Cut . 

Copy 

1. Select text you want to cut. 

2. On the Edit Menu, select Copy . 

Paste  

1. Cut or Copy the item you want to Paste. 

2. Reposition the insertion point at the target location. 

3. On the Edit Menu, select Paste . 

 

If the text contains formatting from Word, you will receive a message ―The text you 
want to paste seems to be copied from Word. Do you want to clean it before 
posting?‖ Refer to Paste from Word below. 

If the text contains formatting from non-Word applications, the HTML editor will 
copy the formatting when the item is pasted. 

Paste as plain text 

1. Cut or Copy the item you want to Paste. 

2. Reposition the insertion point at the target location. 

3. On the Edit Menu, select Paste . 

Paste from Word 

1. Cut or Copy the item you want to Paste. 

2. Reposition the insertion point at the target location. 

3. On the Edit menu, select Paste from Word . 
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4. Do you want to clean the text before posting? 

If Then 

Yes 1. Click OK. 

2. In Paste from Word: 

 

a. Paste your text in the box provided. 

b. Check Ignore Font Face definitions to remove the Word font 
styles. 

c. Check Remove Style definitions to remove the Word formatting 
styles. 

d. Click OK. 

No Your text is pasted from Word, applying the Word styles and formatting.   

 

Find 

1. On the Edit Menu, select Find . 
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2. On the Find dialog, complete the following fields: 

 

Field Description 

Find What The text you want to search for. 

Match case Match the case format. 

Match whole 
word 

Match the full word(s). Ignores partial matches. 

a. Click Find. 

b. Click Cancel to close the dialog. 

Replace 

1. On the Edit Menu, select Replace . 

2. On the Replace dialog, complete the following fields: 

 

Field Description 

Find What The text you want to search for. 

Replace With The replacement text. 

Match case Match the case format. 
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Field Description 

Match whole 
word 

Match the full word(s). Ignores partial matches. 

a. Click Replace or Replace All. 

b. Click Cancel to close the dialog. 

Select All 

To select all text: 

 On the Edit menu, select Select All .  

Remove format 

1. Select the text from which you want to remove formatting. 

2. On the Edit menu, select Remove Format .  
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Creating Macros 

Macros are preprogrammed shortcuts which perform a series of actions. Macros can be created 
and shared across courses, groups and resource libraries to which you have editor access.  The 
creation of macros allows you to create the item once and use it multiple times in your courses, 
groups or resource libraries. 

For example, if you‘d like to automatically insert a salutation (e.g. Hello class!) at the beginning 
of each page, you can create a macro which allows you to insert the phrase, versus retyping it 
for every page. 

After your macro has been created you can use it on the page you are creating or share it in 
other course, groups or resource libraries to which you have editing rights. 

The following is a list of macro tools: 

Icon Description 

 
Insert/Edit Macro- allows you to create or edit shortcuts that perform a 
series of actions 

Create a new Macro 

1. Click Insert/Edit Macro . 

2. Click the New Macro tab. 

3. In the New Macro tab, complete the following fields: 
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Field Action 

Name The name of your macro. 

Category The category for the macro. Do one of the following to define the 
category: 

 Chose the category from the drop-down-down list . 

 Click the new macros button to create a new category 

Macro 
text 

The text to be inserted into the text area when the macro is played.  
Formatting of the text requires HTML tags.  

4. Click Save. 

Edit a Macro 

1. Click Insert/Edit Macro . 

2. On the Macro dialog, select the Category from the drop-down-down list.   

3. Select the macro you want to edit and click Edit. 

4. On the Existing Macros tab: 

 

a. Update the name, category and macro text as necessary. 

b. Click Save.   
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To apply the updated macros to your new page, you will need to use the Insert a 
Macros function. 

You can past HTML from Source, but not from the editor window. 

Insert a Macro 

1. Click Insert/Edit Macro . 

2. On the Macro dialog 

 

a. Select the Category from the drop-down-down list.   

b. Click the macro you want to insert from the category on the left side of the 
window. 

c. Click the OK button.   

Delete a Macro 

1. Click the Insert/Edit Macro icon.  
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2. On the Macro dialog: 

 

 

a. Select the Category from the drop-down-down list.   

b. Click the macro you want to delete. 

c. Click Delete. You are prompted, ―Permanently delete this item?‖  

If Then 

Yes Click OK to delete the macros from your list and from the Category 
options.  

No Click Cancel to return you to the Existing Macros tab. 

 

d. Click the OK button.   

Share a Macro 

1. Click the Insert/Edit Macro icon.  

2. On the Macro dialog, select the Category from the drop-down-down list.  Your list of 
macros from that category is listed in the text area on the left side. 

3. Select the macro you want to share. 
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4. Click Share. 

 

5. Complete the following fields: 

Field Description 

Share with… The minimum course rights required to use the shared macro. 

In these sections… The course/group section to share the macro with. 

6. Click Save. 
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Inserting Hyperlinks 

A hyperlink is a link from one page or file to another. On a page, you may want to insert a 
hyperlink to some other website or to a document you uploaded to you server. A hyperlink is 
usually displayed by a distinguishing feature such as a different color, font or style. When a 
hyperlink is clicked, the destination is displayed, opened, or run, depending on the type of 
destination. The destination is frequently another page, but it can also be a picture, a multimedia 
file, a document, an e-mail address, or a program. 

 

To create, edit and remove hyperlinks, you will use the following tools found on the Link Menu: 

 

Icon Description 

 

 

 

Insert/Edit Web Link - Add or remove hyperlink from highlighted 
text. Used to add or edit links outside the ANGEL environment or 
an anchor within a page. 

 

 

Insert Content Link - Used to create links to areas in system where 
links exisit or will exist based on an upload. 

 
Remove Link - allows you to remove a hyperlink you‘ve inserted in 
a page. 

 
Anchor - allows you to create bookmarks within pages inside and 
outside of ANGEL. 

Web Link  

A web link is used to create a reference or navigation element to another section of the same 
page, to an email or to another page on the internet. 

Create a link to a web address (URL) 

1. Select the text or image you want to use as the hotspot for the link. 
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2. Click Web Link . 

 

3. On the Link info tab, complete the following fields: 

Field Description 

Link Type Specifies link type (e.g. URL, Link to anchor in the text, E-mail). For a 
web link to a page on the internet, select URL. 

Protocol Specifies the protocol from the drop-down list. (e.g. http, https, ftp, 
news, other). 

URL Specifies the URL or address of the web page the link will display. 
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4. Click the Target tab. 

 

5. Optionally, complete the following fields: 

Field Description 

Target Type 

 

Select the Target Type from the drop-down list.  

 Frame: A frame within the current frame. 

 Pop-up Window: Opens in a pop-up window. 

 New Wndow: Opens in a new window. 

 Topmost Window: Opens in topmost window which 
replaces your current window. 

 Same Widow:  Opens in the same window you are using. 

 Parent Window:  Opens in new window unless you are in 
frames.  

Target Frame 
Name box 

When using the target type of Frame, this specifies the name of 
the frame the target displays. 
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6. Click the Advanced tab. 

 

7. Optionally, complete the following: 

Field Description 

Id The id attribute may be used to create an anchor at the start tag 
of any HTML element. (HTML Id attribute). 

Language 
Direction 

Specifies the base direction of directionally neutral text. Possible 
values:  

 Left-to-right  

 Right-to-left  

Access Key A single character that defines the shortcut key (ALT + character) 
that "clicks" on the link.  

Name The anchor name.  Used to link to an anchor within a page. 

Language 
Code 

Specifies the base language of the target URL. 

Tab Index Defines the position in tabbing order. 

Advisory Title Defines the text that displays when the user moves the mouse 
over the link. 

Advisory 
Content Type 

Provides gives an advisory hint as to the content type of the 
target URL. Examples include "text/html", "image/png", 
"image/gif", "video/mpeg", "text/css", etc. 

Stylesheet 
Classes 

Assigns a class name or set of class names to an element. 
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Field Description 

Linked 
Resource 
Charset 

Specifies the character encoding of the target URL.  

Style Allows entry of custom CSS style information for the element. 

8. Click OK. 

Create a link to an e-mail address 

1. Click Web Link . 

2. On the Link info tab, select E-mail from the Link Type. 

 

3. Complete the following fields: 

Field Description 

E-mail 
Address 

The recipients email address 

Message 
Subject 

The subject of the message to be sent. 

Message 
Body 

The information to be contained in the message body. 
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9. Click the Advanced tab. 

 

10. Optionally, complete the following: 

Field Description 

Id The id attribute may be used to create an anchor at the start tag 
of any HTML element. (HTML Id attribute). 

Language 
Direction 

Specifies the base direction of directionally neutral text. Possible 
values:  

 Left-to-right  

 Right-to-left  

Access Key A single character that defines the shortcut key (ALT + character) 
that "clicks" on the link.  

Name The anchor name.  Used to link to an anchor within a page. 

Language 
Code 

Specifies the base language of the target URL. 

Tab Index Defines the position in tabbing order. 

Advisory Title Defines the text that displays when the user mousse-over the 
link. 

Advisory 
Content Type 

Provides gives an advisory hint as to the content type of the 
target URL. Examples include "text/html", "image/png", 
"image/gif", "video/mpeg", "text/css", etc. 

Stylesheet 
Classes 

Assigns a class name or set of class names to an element. 
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Field Description 

Linked 
Resource 
Charset 

Specifies the character encoding of the target URL.  

Style Allows entry of custom CSS style information for the element. 

 

11. Click OK. 

Edit web link 

1. Right-click on the hyperlink and click Edit Link. 

Remove web link 

2. Select the hyperlink you want to remove. 

3. Do one of the following: 

 On the File Menu, select Remove Link . 

or 

Click the Insert/Edit Content Link . 

 In the URL box, highlight the URL and press Delete. 

or  

Right-click on the hyperlink and click Remove Link. 

Content Link 

A content link is used to create a reference or navigation element to an item within the ANGEL 
LMS environment.  There are five different areas which you can link to from a course: 

Content 
Area 

Description 

Personal 
Files 

Personal Files allows you to link to files stored in your personal file manager 
(within the Toolbox select Personal Home page > Files link). This is useful for 
users who want to link to the same file resource from multiple courses or 
locations. This approach is not recommended when building a master course 
image that will be used by multiple instructors because the source image 
would be deleted in the event the instructor‘s account is ever deleted from the 
system. 

Associated 
Files 

Associated Files displays all file resources (html page, images, PowerPoint, 
Adobe .pdf, etc.) uploaded to the current content item. This is the 
recommended location for file resources if the content item needs to remain 
portable – meaning that the content item (quiz, page, folder, etc.) needs to 
support export to a different course or location as is commonly the case with 
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Content 
Area 

Description 

content items in learning object repositories. When a content item is exported 
or copied from another course, all file resources for the content item are 
exported/copied as well. 

Course Files Course Files displays the root view of all associated files for all content items 
in the course. This option can be helpful when dealing with multiple content 
items that need to the same file resources within the course (i.e. repeated 
course images, etc.). File resources within the course file manager are always 
exported with the course, but are not included when importing/exporting a 
single content item (i.e. from a repository). Therefore, this approach can be 
effective for individual instructor courses and master courses, but should not 
be used to store file resources for repository content items. 

 
WebCT/Bb/IMS/Standard Zip Import all place their files in the 
Course Files area. 

  

Map The Map displays a birds-eye view of the course content, course tabs and 
select course tools/reports allowing the editor to create links to specific 
content items, tools or tabs. If HTML anchors exist in the page item or an 
uploaded webpage, the appropriate syntax (i.e. #anchor1) can be added to 
the end of the resultant link to provide direct navigation to that portion of the 
document. 

Icons The Icons area displays a list of image resources that has been populated by 
your institutions ANGEL Administrator. This option can be helpful when 
dealing with content which applies to any course/group within the system (e.g. 
logo's, banners, icons). The location of these icons is in the 
...\AngelThemes\System\Icons\ area within ANGEL. 

 

Insert content link 

1. Do one of the following: 

 Select Insert Content Link.  

 On the Link Menu, select Content Links . 

2. On the Content Links dialog, do the following: 

 Choose the tab for which you need to upload files. 

 Click New Folder to create a new folder, if applicable. 

3. On the tab(s) you‘ve selected, do the following:  

 Click Browse and select a file. (Available for Personal, Associated or Course 
only.) 

 Click Upload File. 
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or 

 In the Path box, select an existing file, map path or icon. Your link will be inserted 
into the HTML editor window.  

Edit content link 

1. Right-click on the hyperlink and click Edit Link. 

2. On the Content Links dialog, edit the hyperlink properties. 

3. Click OK. 

Remove content link 

1. Select the hyperlink you want to remove. 

2. Do one of the following: 

 On the File Menu, select Remove Link . 

or 

Click the Insert/Edit Content Link . 

 In the URL box, highlight the URL and press Delete. 

or  

Right-click on the hyperlink and click Remove Link. 

 

Using Anchors 

An essential feature of a web pages is the ability to connect (hyperlink) pages, media files and 
programs.  A hyperlink can be made from one resource to another or from one location within a 
resource to another. Both the source and the destination of a link are anchors (sometimes 
called bookmarks). 

For example, you may have a page with several topics. At the end of each topic, you may want 
to include an anchor which when clicked will bring users back to the top of a topic or back to the 
table of contents. 

Creating an anchor is a two step process. First, you will create an anchor and then you will 
create a link to the anchor.   

When creating an anchor, naming it is very important. The name is an opportunity to remember 
for what purpose you created it. In the example above, you might name your anchor ‗top‘, which 
signifies that by clicking the anchor, you will be returned to the top of a page or section. 

Some other tips for naming your anchors: 

 Create short, one word names. 

 Do not use underscores ( _ ). 

 Do not use uppercase letters. Some web browsers differentiate between upper and 
lowercase. 
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 Do not include punctuation marks or symbols. 

 Do not use numbers. 

Add an anchor 

1. Position the insertion point at the target location. 

2. On the File Menu, select Anchor . 

 

3. In the Anchor Properties dialog, type the Anchor Name.  The anchor icon  will 
appear at the anchor point. 

Insert a link to an anchor 

1. Select the text or image you want to use as the hotspot for the link. 

2. Click Web Link . 

3. On the Link tab, select Link to anchor in text from the Link Type list.  

 

4. Complete one of the following: 
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 Select an anchor by Anchor Name. 

 Select an anchor by Element Id. 

5. Click OK. 
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Tables 

A table is made up of columns and rows of cells into which you can insert text and graphics.  
There are several different ways you can use tables, and you can customize your tables in a 
variety of ways to make them more attractive and easy to read. 

The tables tool allows you to arrange data such as text, images, links, forms, etc. into columns 
and rows of cells.   

Create a table and set its properties 

1. Position the insertion point where you want to insert the table.  

2. Do one of the following: 

 Click Insert/Edit Table .  

 Click the Table Menu and select Insert/Edit Table . 

 

3. Complete the following: 

Field Name Description 

Rows Specifies the number of rows.  

Columns Specifies the number of columns.  

Alignment Specifies the position for the table on the page.  

Width Specifies the width of the table in either pixels or as a percentage 
of the window width. 

Height Specifies the height of the table in pixels. 

Border size Specifies the width you want for the table border in pixels. If you 
do not want a border, type 0.  
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Field Name Description 

Cell spacing Specifies a number in the Cell padding box.  

Cell padding Specifies a number in the Cell spacing box.  

Caption Specifies a caption in the Caption box. 

Summary Specifies a summary of the table for use with speech-synthesizing/ 
non-visual browsers, if applicable. 

 

4. Click OK. 

 
When a table is present on your page you can right-click in the table and a pop-up 
menu is presented with possible table operations. 

Cell Properties  

Tables are comprised of cells. Each cell can be formatted by using cell properties.  

Set the properties of a table cell 

1. Select the cells you want to change.  

2. Right-click, and then click Cell > Cell Properties on the pop-up menu.  

 

3. Complete the following fields: 

Field Name Description 

Width Specifies the size of the cell width in either pixels or as a percent. 

Height Specifies the size of the cell height in pixels. 

Word Wrap Allows text to wrap in a cell  
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Field Name Description 

Horizontal 
Alignment 

Specifies the horizontal position for the text within the cell.  

Vertical 
Alignment 

Specifies the vertical position for the text within the cell. 

Row Span Specifies the number of rows you want the cells to span.  

Column Span Specifies the number of columns you want the cells to span.  

Background 
Color 

Specifies the color background. 

Border Color Specifies the border color of tables. 

 

4. Click OK. 

Add a cell, row, or column to a table 

Insert a cell 

1. Position the insertion point in a cell to the left of where you want to add a cell.  

2. On the Table menu of the toolbar, select Insert Cell . 

Insert a row 

1. Position the insertion point in a cell above where you want to add a new row.  

2. On the Table menu of the toolbar, select Insert Row . 

Insert a column 

1. Position the insertion point in a cell to the left of where you want to add a new 
column.  

2. On the Table menu of the toolbar, select Insert Column . 

Insert a table within a table 

1. Position the insertion point in a cell where you want to add a new table.  

2. Do one of the following: 

 Click Insert/Edit Table. 

 On the Table menu of the toolbar, select Table . 

Formatting table cells 
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Split cells  

1. Position the insertion point in the cell you want to divide.  

2. Right-click the cell and then click Cells > Split Cells on the pop-up menu. 

Merge cells  

1. Select the cells you want to combine.  

2. Right-click the selection and then click Cells > Merge Cells on the pop-up menu. 

Delete all or part of a table 

Delete a table 

1. Select the cells you want to delete.  

2. Right-click and select Delete Table on the pop-up menu. 

Delete a cell 

1. Select the cells you want to delete.  

2. On the Table menu of the toolbar, select Delete Cell . 

Delete a row 

1. Select the rows you want to delete.  

2. On the Table menu of the toolbar, select Delete Row . 

Delete a column 

1. Select the columns you want to delete. 

2. On the Table menu of the toolbar, select Delete Column . 
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Inserting Image, Flash and Movies 

In the  HTML editor, you can add images, Flash presentations and movies. These elements 
visually enhance your pages as well as provide rich content for a variety of audiences and 
learning types. 

You can use images on your page for a variety of reason. In addition to being decorative, 
graphics can be useful in providing information, examples or even navigational buttons.  

The Media menu, contains the following tools: 

Icon Description 

 

 

Image - inserts an image (e.g. .jpg, .tiff, .bmp) 

 
Flash - inserts a Flash presentation file. 

 
Movie - inserts a movie file. This could be an .mp3, au, avi, wmv… 

 

Using Images  

Images are a good way to make your content more visual. Images can include elements such 
as logos, line art, simple graphics.  There are several image formats that can be used on the 
internet.  The following are the most common.   

Format Description 

.gif GIF (Graphics Interchange Format) is an 8-bit-per-pixel bitmap image format that 
was introduced by CompuServe in 1987 and has since come into widespread 
usage on the World Wide Web due to its wide support and portability. 

The format uses a palette of up to 256 distinct colors. It also supports animations 
and allows a separate palette of 256 colors for each frame.  

.jpg JPEG (Joint Photographic Experts Group) provides for lossy compression of 
images. The file format is typically used for high-end images or photographs.    

The format uses a palettes of  16.7 million colors. 

.png PNG (Portable Network Graphics) is a bitmapped image format that employs 
lossless data compression. PNG was created to improve and replace the GIF 
format, as an image-file format not requiring a patent license.  

The format uses a palettes of 24-bit RGB colors or grayscale. 

   

Add images  
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1. Position your cursor where you want to insert the image. 

2. Do one of the following 

 Click the Insert/Edit image .  

 On the Media Menu, select Image . 

 

3. On the Image Properties dialog, complete the Image Info tab: 

Field Description 

URL The web address of the image to display.  Click Browse to 
navigate to the image location. 

Alternative Text Used by Web browsers to display text during image downloads 
for users who have graphics turned off, and for users who rely 
on screen-reading software to convert graphics on the screen to 
spoken words.  

Width Sets the width of an image.  Can be enters in pixels or as a 
percentage. 

Height Sets the height of an image.  Can be enters in pixels or as a 
percentage. 

 Lock Ratio Select to lock image aspect ratio (relationship of the height and 
width of an image).  When selected, re-sizing wither the height 



A N G E L ®  H T M L  E D I T O R  R E F E R E N C E  M A N U A L  

51 

Field Description 

or width automatically maintains the ratio of the other. 

 Reset Size Select to reset the image to its original size. 

Border The size of the border in pixels around the graphic. This is a 
way to indicate that they can click the graphic. 

HSpace Defines white space, in pixels, on the left and right side of the 
image. 

VSpace Defines white space, in pixels, on the top and bottom of the 
image. 

Align Specifies how to align the image according to surrounding text. 
Left - Aligns the image will be left justified. Text will begin at the 
top of right of the image 

 Abs Bottom - Aligns the bottom of the first line of text with 
the bottom of the image 

 Abs Middle - Aligns the top of the first line of text with the 
middle of the image 

 Baseline - Aligns the bottom of the image with the baseline 
of the text. The baseline is the line along which the bottom 
of most letters rest, but below which some letters dangle, 
such as j and y.  

 Bottom  - Aligns the bottom of the image aligns with the 
baseline of the line containing the image. 

 Middle - Aligns the center of the image aligns with the 
bottom of the first text line  

 Right - Aligns the image will be right justified. Text will start 
at the top left of the image 

 Text Top - Aligns the first line of text will align with the top of 
the image.  

 Top - Aligns the top of the image aligns with the tallest item 
on the line containing the image. 

 

4. If the image to be used as a hyperlink. Click the Link tab. 
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5. On the Link tab, complete the following: 

 

Field Description 

URL The web address of the link to display when the image is 
clicked.  Click Browse to navigate to the link page. 

Target Select the Target from the drop-down list.  

 New Window (_blank): Opens in a new window. 

 Topmost (_top): Opens in topmost window which replaces 
your current window. 

 Same Widow (_self):  Opens in the same window as the 
image. 

 Parent Window (_parent):  Opens in new window.. 

 

6. Optionally, click the Advanced tab 
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7. Optionally, complete the following: 

Field Description 

Id The id attribute may be used to create an anchor at the 
start tag of any HTML element. (HTML Id attribute). 

Language 
Direction 

Specifies the base direction of directionally neutral text. 
Possible values:  

 Left-to-right  

 Right-to-left  

Language 
Code 

Specifies the base language of the target URL. 

Long 
Description 
URL 

Specifies the URL of a document that contains an 
extended description of the resource. 

Stylesheet 
Classes 

Assigns a class name or set of class names to an 
element. 

Advisory Title Defines the text that displays when the user mousse-over 
the link. 

Style Allows entry of custom CSS style information for the 
element. 
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8. Click OK. 

 
Click Cancel to exit the window without making changes. 

Using Flash  

Flash, refers to both the Adobe Flash Player and to a multimedia authoring program used to 
create content (such as web applications, games and movies).  Flash presentations are a good 
way to add interactive content to your pages.  

Adding Flash presentations  

1. Position your cursor where you want to insert the Flash presentation. 

2. On the Media Menu, select Flash . 

 

3. On the Flash Properties dialog Info tab, complete the following fields: 

Field Description 

URL Specifies a web address of the Flash file.  Select the browse button 
to navigate to the file if it is located in the course or is to be uploaded 
to the course. 

Width Specifies the width to display the Flash presentation in pixels. 
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Field Description 

Height Specifies the height to display the Flash presentation in pixels. 

 

 
You can preview your Flash file in the Preview pane. 

 

4. Click the Advanced tab. 

 

5. Optionally, complete the following 

Field Description 

Scale  Allows you to specify the scale of the movie.  Options include: 

 Show all makes the entire movie visible in the specified 
area without distortion, while maintaining the original 
aspect ratio of the movie. Borders may appear on two 
sides of the movie.  

 No Border scales the movie to fill the specified area, 
without distortion but possibly with some cropping, while 
maintaining the original aspect ratio of the movie.  

 Exact Fit makes the entire movie visible in the specified 
area without trying to preserve the original aspect ratio. 
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Field Description 

Distortion may occur. 

Auto Play Specifies whether the movie begins playing immediately on 
loading in the browser. 

Loop Specifies whether the movie repeats indefinitely or stops 
when it reaches the last frame. 

Enable 
Flash 
Menu 

Gives users a several options for controlling the video. 

Id The id attribute specifies a unique identifier which maybe 
used in CSS styling or DOM manipulation. 

Stylesheet 
classes 

A space separated list of CSS classes to apply to the 
element. 

Advisory 
Title 

Defines the text that displays when the user mousse-over the 
link. 

Style Allows entry of custom CSS style information for the element. 

 

 
Auto Play, Loop and Enable Flash Menu are checked by default. 

 

6. Click OK. 

 
Click Cancel to exit the window without making changes. 

 

Using Movies 

Movies are a good way to make your content more engaging. Movies are generally different 
from Flash presentations in that movies are larger in files size and movies cannot contain Flash 
presentations (versus Flash presentations which are generally smaller in file size, contain much 
more animation and can contain movies). 

There are several movie formats that can be used on the internet.  The following are the most 
common.  For each movie format, a plug-in or helper application must be installed on the 
computer of the user viewing the movie. 

Format Description 

.avi Short for audio/video interleaved. Originally developed as a rival to Quicktime 
format for Windows machines but will be playable on most computers via helpers 
and plug ins. It can use several compression schemes and is becoming 
increasingly popular. Most digital video cameras shoot in .avi format 
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Format Description 

.mov These file types are based on the Quicktime (QT) system. It's designed initially 
for the Mac platform but is now usable via a plugin and helper application on 
most other operating systems. You can load the standard quicktime player™ 
from Apple for free as well as get access to a host of resources. QT has some 
great compression schemes which often make QT files smaller without loss of 
quality. 

.mpeg This format takes it's name from the developing group (motion Pictures Expert 
Group). Remains an important web video file type due to the range of 
compression that can be applied. Unlike avi and Qucktime not developed for a 
particular operating system. 

.wmv  Windows Media Video. Part of Microsoft's windows media format WMV files can 
be downloaded or streamed. Microsoft have tons of resources at 
http://www.microsoft.com/windows/windowsmedia/default.asp many of which are 
free to download. 

.rm RealVideo® files. These are the archetypial streamed video files. One of the first 
and still most popular streamed media format. The basic player can still be 
downloaded for free at http://www.real.com/. 

 

Adding Movies 

1. Position your cursor where you want to insert the movie. 

2. On the Media Menu, select Movie . 
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3. On the Movie Properties dialog, complete the following fields: 

Field Description 

URL Specifies a web address of the Movie file.  Select the 
browse button to navigate to the file if it is located in the 
course or is to be uploaded to the course. 

Auto size Automatically creates a display size for the player based on 
the size of the movie clip. 

Auto play Automatically begins to play the movie once the page is 
loaded. 

Show 
gotobar 

The GoToBar looks for markers that have been inserted 
into the movie file and create a drop-down table of contents 
for the file allowing users to skip to a particular section. 

Show 
statusbar 

Shows users how long the movie has been playing, how 
much time is left. Anything else? (Don’t Know) 

Show 
controls 

   Position 
controls 

   Tracker 

    Auto 

Automatically displays the movie controls. Position controls 
automatically places controls in a certain area of the 
window. What is tracker and auto controls? (Don’t Know) 
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controls 

URL Specifies a web address of the Movie file.  Select the 
browse button to navigate to the file if it is located in the 
course or is to be uploaded to the course. 

 

 
Auto size, Show controls, Position controls, Tracker, and Auto controls are 
checked by default. 

4. Click OK. 

 
Click Cancel to exit the window without making changes. 
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Forms 

A form is a collection of fields that you use for gathering information from your page. Visitors fill 
out a form by typing text, clicking radio buttons and check boxes, and selecting options from 
drop-down menus. After filling out the form, visitors submit the data they entered, which can be 
processed in a variety of ways depending on the form handler you set up. 

The general steps in creating a form are:  

1. Decide what kind of information to collect, and then start a form.  

2. Add fields to the form.  

3. Set up how you want to handle the information you collect from the form.  

Form fields are the individual fields on a form that are used to gather information.  Each field is 
identified by a Name and Value pair. The Name is the identifier for the form elements that can 
be referred by name once the form is submitted.  The Value field is the information entered by 
the visitor.  For example, if you define a text field named MyField, and the visitor enter Hello 
World into the field and submits the form;  the name/value pair would be MyField=hello world. 

Text Field 
Use text fields to collect a small amount of text, 
such as a name or a number. 
 

Enter your e-mail address: 

someone@microsoft.com
 

Radio buttons 
Use radio buttons when you want the site 
visitor to select only one option from a group. 
 

A     B     C 

Text Area 
Use text areas to collect one or more lines of 
text, such as a comment. This field scrolls to 
accommodate varying amounts of text. 
 

Sign my guest book: 

 

Selection field  
Use a selection field to present the site visitor 
with a list of choices. This field is similar to 
using a group of radio buttons, but takes less 
space on your form. You can configure a drop-
down menu to allow one or multiple selections. 
 

Select a product: 
Product 1

 

Checkbox 
Use check boxes for optional items. The site 
visitor can select or clear the check box. They 
can also select multiple items. 
 

Yes, I would like to receive updates 

Button 
Use buttons to let site visitors submit the form 
after filling it out, clear fields by resetting the 
form or run your custom scripts.  

 

 

After a visitor submits the form, you must collect the data that was entered — the form results — 
so you can view them, display them to the visitor, or work with them as needed.   ANGEL 
provides a technique which saves the results to a file associated with the Lesson item (post.htm 
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in the Associated File Manager for the item). Each time a visitor submits a form, the results are 
append the file. You can then open the file and view the results.   

Define the Form 

Before adding form elements, you must first define the form. 

 

1. Do one of the following: 

 Click the Form  icon. 

 On the Form Menu, select Form . 

2. On the Form dialog, complete the following fields: 

 

Field Description 

Name Type a name for your form.  

Action Type the name of the form handler.   

If you are using the ANGEL form handler, type 
$POST_URL$ into the Action field. 

Method Select GET or POST.   

 GET passes the form information to the form handler 
(Action) via the URL. As the total size of a request 
(URL+params) approaches or exceeds 1Kb, you are 
well-advised to use POST in any case. 

 POST passes the form information to the form handler 
(Action) in the body of HTTP request.  There is no size 
limit on the amount of information being sent via POST.  
If you are using the ANGEL  

If you are using the ANGEL form handler, select POST. 
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A red dotted line appears in the  HTML Editor. You can now add elements to your 
form 

Add Form Elements 

Forms are comprised of different elements. You can select to have your audience complete text 
fields or you can simplify answers and have them click radio buttons and checkboxes. 

 

Element Description 

 
Use check boxes for optional items. The site visitor can select or 
clear the check box. They can also select multiple items. 

 
Use radio buttons when you want the site visitor to select only 
one option from a group. 

 
Used as one line areas that allows the user to input text. If you 
want several lines, use a text area. 

 
Used as several lines in an area which allow the user to input 
text. If you want the user to input one line only, use a text area. 

 
Use a drop-down menu to present the site visitor with a list of 
choices. This field is similar to using a group of radio buttons, but 
takes less space on your form. You can configure a drop-down 
menu to allow one or multiple selections. 

 
Buttons offer richer rendering possibilities. The BUTTON element 
may have content.  

 
Has the same effect as submit buttons. When a visitor clicks an 
image button the form is sent to the address specified in the 
action setting of the tag. 

 
Is similar to text fields, except that hidden field does not show on 
the page. It allows the form to submit information that is not 
entered by the visitor. Use hidden fields when you have variables 
you want to pass from one form to another without forcing the 
user to re-type information over and over again. 

 

Add a checkbox 

1. Position your cursor where you want the checkbox. 

2. On the Forms Menu, select Checkbox . 

3. On the Checkbox dialog, complete the following fields: 
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Field Description 

Name Type a name for your checkbox. 

 If you are using the ANGEL form handler, type 
$POST:fieldname$ into the Name field (where fieldname is 
replaced by the name of the HTML form field). 

Value The value for the box. 

Selected Select if you want the checkbox to be checked by default. 

4. Click OK. 

5. Type the text you wish your audience to see. 
 

Add a radio button 

1. Position your cursor where you want the radio button. 

2. On the Forms Menu, select Radio Button . 

3. On the Radio Button dialog, complete the following fields: 
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Field Description 

Name Type a name for your radio button. 

 If you are using the ANGEL form handler, type 
$POST:fieldname$ into the Name field (where fieldname is 
replaced by the name of the HTML form field). 

Value The value for the box. 

Selected Select if you want the checkbox to be checked by default. 

 

4. Click OK. 

5. Type the text you wish your audience to see. 

Add a text field 

1. Position your cursor where you want the text field.. 

2. Click Form Menu and select Text Field . 

3. On the Text Field dialog, complete the following fields: 

 

Field Description 

Name Type a name for your text field. 

 If you are using the ANGEL form handler, type 
$POST:fieldname$ into the Name field (where fieldname is 
replaced by the name of the HTML form field). 

Value The value for the box. 

Character 
width 

Type the width in pixels. 
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Maximum 
Characters 

Type the maximum number of characters that can be 
entered in the field. 

Type Select Text or Password from the drop-down list. 

 

4. Click OK. 

Add a text area 

1. Position your cursor where you want the form area. 

2. Click Form Menu and select Textarea . 

3. On the Textarea dialog, complete the following fields: 

 

Field Description 

Name Type a name for your text area. 

 If you are using the ANGEL form handler, type 
$POST:fieldname$ into the Name field (where fieldname is 
replaced by the name of the HTML form field). 

Rows Type the number of columns wide the field will be. 

Columns Type the number of rows high the field will be. 

 

4. Click OK. 

Add a selection field 

1. Position your cursor where you want the selection field. 

2. Click Form Menu and select Selection Field . 
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3. On the Selection Field dialog, complete the following fields: 

 

Field Description 

Name Type a name for your text area. 

 If you are using the ANGEL form handler, type 
$POST:fieldname$ into the Name field (where fieldname is 
replaced by the name of the HTML form field). 

Size Type the number of lines you want your selection field to 
have. 

Allow 
multiple 
selections 

Check if you want your form to allow several options to be 
selected. 

Available 
options 

Type your option. 

Value The value for the box. 

 

4. Click Add. 

5. Other options for selection fields are available. 

If you wish to Then 
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set a certain option as 
the default, 

Click the Set as selected value button. 

delete an option, Select the option you wish to delete and click 
Delete. 

move the selection,  Click the Up or Down buttons to move the 
selection. 

modify an option, 1. Select the option.  

2. Complete your changes in the Text and Value 
boxes.  

3. Click Modify. 

 

Add a button 

1. Position your cursor where you want the button. 

2. On the Form Menu, select Button . 

3. On the Button dialog, complete the following: 

 

Field Description 

Name Type a name for your button. 

Value The text to appear on the button face. 

Type The action to be taken when the button is pressed: 

 Button – No default action.  A custom script must be 
used to perform an action when this button type is 
pressed. 

 Submit – Submits the form. 

 Reset – Clears the form field.   
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4. Click OK. 

Add an image button 

1. Position your cursor where you want the Image button. 

2. In the Form Menu, select Image Button . 

3. On the Image Info tab, complete the following: 

 

Field Description 

URL Browse the server for the image or enter a URL. 

Short 
Description 

Describe your button. 

Width Set your images‘ width. When a picture is selected, the width 
is automatically set. You can change it by highlighting the 
width and entering in the width you want. 

Height Set your images‘ height in pixels.  

Border Set your images‘ border size. When a picture is selected, the 
height is automatically set. You can change it by highlighting 
the height and entering the heighth you want. 
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Field Description 

HSpace Set the horizontal space around your image. HSpace defines 
the amount of white space to be inserted to the left and right 
of an image. 

VSpace Set the vertical space around your image. VSpace defines 
the amount of white space to be inserted above and below an 
image. 

Alignment Specifies how to align the image according to surrounding 
text. Left - Aligns the image will be left justified. Text will begin 
at the top of right of the image 

 Abs Bottom - Aligns the bottom of the first line of text with 
the bottom of the image 

 Abs Middle - Aligns the top of the first line of text with the 
middle of the image 

 Baseline - Aligns the bottom of the image with the 
baseline of the text. The baseline is the line along which 
the bottom of most letters rest, but below which some 
letters dangle, such as j and y.  

 Bottom  - Aligns the bottom of the image aligns with 
the baseline of the line containing the image. 

 Middle - Aligns the center of the image aligns with the 
bottom of the first text line  

 Right - Aligns the image will be right justified. Text will 
start at the top left of the image 

 Text Top - Aligns the first line of text will align with the top 
of the image.  

 Top - Aligns the top of the image aligns with the tallest 
item on the line containing the image. 

 

4. Click the Advanced tab. 

5. On the Advanced tab, complete the following: 
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Field Description 

Id The id attribute may be used to create an anchor at the 
start tag of any HTML element. (HTML Id attribute). 

Language 
Direction 

Specifies the base direction of directionally neutral text. 
Possible values:  

 Left-to-right  

 Right-to-left  

Language 
Code 

Specifies the base language of the target URL. 

Long 
Description 
URL 

Specifies the URL of a document that contains an 
extended description of the resource. 

Stylesheet 
Classes 

Assigns a class name or set of class names to an 
element. 

Advisory Title Defines the text that displays when the user mousse-over 
the link. 

Style Allows entry of custom CSS style information for the 
element. 
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6. Click OK. 

Add a hidden field 

1. Position your cursor where you want the hidden field. 

2. Click Form Menu and select Hidden Field . 

3. On the Hidden Field dialog, complete the following. 

 

Field Description 

Name Type a name for your hidden field. 

 If you are using the ANGEL form handler, type 
$POST:fieldname$ into the Name field (where fieldname is 
replaced by the name of the HTML form field). 

Value The value for the hidden field. 

 

4. Click OK.  
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Equation Editor 

The WebEQ Equation Editor has been integrated into the ANGEL HTML editor. It gives editors 
a way to enter mathematical expressions in a web page, much as the text entry controls and 
buttons in typical HTML forms give users a way to enter other kinds of information.  

The Insert Equation function is used with WebEQ Equation Editor, which can be used to create, 
save, and view complex mathematical equations in ANGEL. Equations are built up out of mini-
templates.  These blank templates are small squares that can be filled in.   

When the cursor is in a slot, the parent template is faintly outlined in gray.  Since many 
templates can be nested in a single equation, this helps you keep track of where you are. 

The following is the WebEQ Equation Editor toolbar. 

 

 

A B C D E F G H I J K L M N O P Q 

 

Letter Description  Letter Description 

A Layout palette  B Accents palette 

C Fences palette  D Trigonometry palette 

E Calculus palette  F Matrices palette 

G Arrows palette  H Operators palette 

I Comparison operators palette  J Set theory palette 

K Logical operators palette  L Lowercase Greek palette 

M Uppercase Greek palette  N Function palette 

O Tools menu  P Check for errors 

Q Help menu    

Insert Equation 

1. Do one of the following: 

 Click the Insert Equation  icon. 

 On the Insert Menu, select Insert Equation . 
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2. Position your cursor where you want the equation to appear. 

3. Click the ▼ symbol to expand the menu of an equation. 

4. Select an equation template from the list. 

5. Exchange the placeholders for the characters you want by clicking in each box and 
typing the characters. 

 

The squares indicate areas where you must enter numerical or 
alphabetical values (no special characters, such as commas or quotation 
marks). Values must be entered for all square in an equation. 

You can use TAB to cycle between empty placeholders. 

 

6. Click OK. 

 
You can click Cancel at any time to cancel this action. 

Edit an equation 

1. Select the equation and perform one of the following: 

 Click the Insert Equation  icon. 

 On the Insert Menu, select Insert Equation . 

2. Change the placeholders for the characters you want by clicking in each box and typing 
the characters. 

3. Click OK. 

Delete an equation  

1. Select the equation and Press DELETE. 
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Using the Insert Menu 

The Insert menu offers a variety of tools for special use, including the following: 

 Templates - choose pre-built page layouts for your page design. 
Special Character- allows you to add special symbols such as currency or copyright 
symbols to your page. 

 Universal Keyboard - allows you to type in multiple languages. 

 Line - allows you to insert a line in your document or table cell. 

 Page break- allows you to insert a page break in your page. 

Insert Template 

The pre-defined templates available include the following.   

 Image and Title – One main image with a title and text that surround the image 

 Two Columns - A template that defines two colums, each one with a title, and some 
text. 

 Text and Table - A title with some text and a table. 

 

 
Refer to Appendix A: Customizing Content Templates on how to create 
new templates. 

 

To insert a template: 

1. Position your cursor where you want the Character in your document. 

2. On the Insert Menu, select Templates . 
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3. On the Content Templates dialog, select the template you want to use. The 
template is automatically inserted into the HTML editor. 

Insert a Special Character 

To insert a special Character: 

1. Position your cursor where you want the Character in your document. 

2. On the Insert Menu, select  Insert Special Character . 
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3. On the Select Special Character dialog Click the special character you want. The 
character is inserted into your page.   

 
You can preview the character in the upper right corner of the window by moving 
the mouse over the character. 

 

Universal Keyboard 

With the Universal Keyboard, you can select from several different languages in which to type 
into the editor window. This function is helpful in situations which you need special characters 
such as currency symbols or if you would like to type a word in its original language. 

 

 

Icon Description 

Text editor Your text appears here. 

Language button Select the language with these buttons 

Scroll Allows you to scroll to the language you want 

Keyboard Standard keyboard which allows you to type your text 

Text field Your text appears here. 

Change language 

To change the language 

1. Position your cursor where you want the character in your document. 

2. On the Insert menu, select Universal Keyboard to insert type into your document or 
specific table cell. 

Scroll forward/backward  
Language buttons 

Text editor 

Keyboard 
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3. In the Universal Keyboard dialog, select your language by using the scroll buttons 
and by clicking the appropriate language. 

 
You can click Cancel at any time to cancel this action. 

Insert new language characters 

To insert a new language 

1. Change your language in the Universal Keyboard. 

2. Type your text by clicking each letter or symbol. 

3. Click OK.  

Line  

To insert a horizontal ine: 

1. Position your cursor where you want the line in your page or table cell. 

2. Click the Insert menu and select Line. 

  You can click Cancel at any time to cancel this action. 

 

Page break 

To insert a Page break (takes effect only when the page is printed): 

1. Move your cursor to where you want the page break in your page or table cell. 

2. Click the Insert menu and select Page Break. 

 

 
You can click Cancel at any time to cancel this action. 
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Using Other Tools 

In addition to standard tools which are similar to word processing programs, the  HTML editor 
also gives you the following tools: 

 Spellcheck- Allows you to check large text box entries for misspellings through an easy 
to use interface. In addition, each user can add custom words or spellings to their 
personal dictionary to aid future use of the spell checker tool. The spell checker tool is 
available throughout ANGEL and is accessible through a visible link found below large 
text boxes on all editor screens. 

 Source - Allows you the flexibility to view and fine tune HTML and css styles, or add 
Flash object code, insert JavaScript and other advanced code that is unavailable in the 
WYSIWYG (What You See Is What You Get) portion of the editor.  

 Document Properties - allows you to format your document with settings such as 
language, colors, background type, author and copyright. 

 Preview - allows you to preview your work before or after saving. 

 Save - allows you to save your work. 

Check Spelling 

1. To spell check the page, perform one of the following: 

 Click the Check Spelling  icon. 

 On the File Menu, select Check Spelling . 
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2. If the program finds a questionable word, a Spell Check dialog displays. In this dialog, 
you are given the option to replace the word, replace all, ignore, ignore all, add or 
cancel.  Select the option which is applicable. 

3. When spell check is complete, click OK. 

View the HTML Code 

1. To view the HTML source code, Click Source  icon.  

2. To return the editing mode , Click Source  icon.  

Preview 

To preview the page: 

1. On the File Menu, select Preview . 

Save 

To save your work, do one of the following: 

 Click the Save button on the lower left side of your Page editor window  

or 

 On the File Menu, select Save. 

 

You will return to the list of your lesson pages.  

You can click Cancel at any time to cancel this action. 
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Appendix A: Customizing Content Templates 

The HTML Editor Content Template can be customized and new templates added by modifying 
the file AngelRoot/InlineEditor/fcktemplates.asp. This file contains an XML formatted file that 
provide all of the information needed to allow users to preview templates via an image 
thumbnail before selecting the template. The file format is illustrated below. Additionally, the 
preview thumbnail image files should be placed in the 
AngelRoot/InlineEditor/editor/dialog/fck_template/images/ directory.    

 
Customizing the Content Template requires knowledge of XML, HTML and 
ANGEL Administrator privileges. 

 

Add a new template 

1. Logon to ANGEL with an Administrator account. 

2. Click the Administrator Consol button. 

3. Click the Application File link. 

4. Click the InlineEditor folder. 

5. Click Edit link below the fcktemplates.asp file. 

6. Copy and paste the following XML (only potion in shaded area) into the fcktemplates.asp 
file.  This should be placed within the top node <Templates…></Templates…> and 
between the other template nodes. 

<Templates… >   Top Node 

  <Template…>  Begin existing template 

  </Template…>  End existing template 

  <Template title="Template_Title" image="Template_Thumbnail"> 

  <Description>Template_Description</Description> 

  <Html> 

   <![CDATA[ 

    Template_HTML 

   ]]> 

  </Html> 

 </Template> 

  <Template…>  Begin existing template 

  </Template…>  End existing template 

<Templates… >   Top Node 

 

7. Replace the following with your template details: 

 Template_Title – The title of the template. This title displays in the Content 
Template dialog.  
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 Template_Thumbnail – The thumbnail image file name.  This image  displays in 
the Content Template dialog.  

 Template_Description – The description of the template. This image  displays in 
the Content Template dialog.  

 Template_HTML – The HTML used to build the template when the template is 
selected from the Content Template dialog.  

8. Click Save. 

9. From the the InlineEditor folder, click the following folders to navigate to the thumbnail 
images folder: Editor > Dialog > fck_template > Images 

10. Click the Add Content link.  

11. Click Upload Files. 

12. Click Browse and navigate to the thumbnail image to be uploaded. 

13. Click Upload File. 

14. Click Done. 
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Appendix B: Customizing Styles 

The Styles dropdown menu of the editor can be completely customized. The configuration of 
this menu is controlled by the file ../InlineEditor/fckstyles.asp. This is an XML formatted file that 
allows you to specify any number of custom styles and the particular tags and attribute values to 
add or modify when a style is selected. The default file text is listed below.  

 
Customizing the Styles requires knowledge of XML, HTML and ANGEL 
Administrator privileges. 

 

Add a new style 

1. Logon to ANGEL with an Administrator account. 

2. Click the Administrator Consol button. 

3. Click the Application File link. 

4. Click the InlineEditor folder. 

5. Click Edit link below the fckstyles.asp file. 

6. Copy and paste the following XML (only potion in shaded area) into the fcktemplates.asp 
file.  This should be placed within the top node <Styles…></Styles…> and between the 
other template nodes. 

7.  

<Styles> 

  <Style>  Begin existing Style 

  … 

  </Style>  End existing Style 

  <Style name="Style_Name" element="div"> 

   <Attribute name="class" value="Style_Value" /> 

   <Attribute name="style" value="Style_Value" /> 

  </Style> 

  <Style>  Begin existing Style 

  … 

  </Style>  End existing Style 

<Styles> 

 

15. Replace the following with your template details: 

 Style_Name – The title of the style. This title displays in the Style list.  

 Style_Value – The name of the style to apply to the HTML span 
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i. class – reference to a CSS style in the ANGEL theme or a custom CSS 
page. 

ii. style – The inline CSS Style for the style. 

16. Click Save. 
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Appendix C: Shortcut Keys 

If you use the editor much, you will want to learn a few shortcut keys.  The following are shortcut 
keys that can be used in the HTML Editor: 

Control keys Description 

Ctrl-A Select all text/objects in the editor. 

Ctrl-B Bold the selected text 

Ctrl-C Copy the selected text/objects to the clipboard. 

Ctrl-I Italicize the selected text. 

Ctrl-K Create a Hyperlink from the selected text. 

Ctrl-U Underline the selected text. 

Ctrl-V  Paste the selected text/objects from the clipboard. 

Ctrl-X  Cut the selected text/objects to the clipboard. 

Ctrl-Z Undo the last command/action. 

Shift-Enter Insert a line break (<BR> html tag) 

 

 


